Approved changes feed: RSS · Atom

cpe:2.3:a:wowdevs:sky_addons_–_elementor_addons_with_widgets_&_templates:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorWowdevs (d1c7ca3c-e7a0-5d5a-b15a-8e4ce0d2dcf9)
ProductSky Addons – Elementor Addons With Widgets & Templates (341047b8-8188-5e1c-a4ff-e061399ed6ce)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-7475 vulnerable 2026-06-08 08:08:57.287708 Sky Addons <= 3.3.2 - Authenticated (Author+) Stored Cross-Site Scripting via Custom Script
MEDIUM (6.4)
The Sky Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `sky-custom-scripts` custom post type in all versions up to, and including, 3.3.2. This is due to the custom post type being registered with `capability_type => 'post'` and `show_in_rest => true`, combined with insufficient input sanitization on the `sky_script_content` meta field and lack of output escaping when rendering scripts on the frontend. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts via the REST API that execute on every frontend page for all site visitors.
Published: 2026-05-08T09:26:47.644Z
Updated: 2026-05-08T12:12:36.653Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-8216 vulnerable 2026-06-08 07:45:19.821726 Sky Addons for Elementor <= 3.1.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets
MEDIUM (6.4)
The Sky Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Multiple widgets in all versions up to, and including, 3.1.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-07-29T09:23:44.652Z
Updated: 2026-04-08T16:37:19.320Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-9542 vulnerable 2026-06-08 07:00:28.151218 Sky Addons for Elementor <= 2.6.1 - Authenticated (Contributor+) Sensitive Information Exposure via Content Switcher Widget Elementor Template
MEDIUM (4.3)
The Sky Addons for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.6.1 via the render function in modules/content-switcher/widgets/content-switcher.php. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive private, pending, and draft Elementor template data.
Published: 2024-11-21T11:02:19.986Z
Updated: 2026-04-08T16:46:56.443Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-2286 vulnerable 2026-06-08 06:33:30.770434 Sky Addons for Elementor <= 2.4.0 - Authenticated(Contributor+) Stored Cross-site scripting via Wrapper Link URL
MEDIUM (6.4)
The Sky Addons for Elementor (Free Templates Library, Live Copy, Animations, Post Grid, Post Carousel, Particles, Sliders, Chart) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the wrapper link URL value in all versions up to, and including, 2.4.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-03-13T15:27:17.958Z
Updated: 2026-04-08T17:26:12.722Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-11601 vulnerable 2026-06-08 06:23:49.941363 Sky Addons for Elementor (Free Templates Library, Live Copy, Animations, Post Grid, Post Carousel, Particles, Sliders, Chart, Blogs) <= 2.6.1 - Cross-Site Request Forgery to Limited Arbitrary Options Update
HIGH (8.1)
The Sky Addons for Elementor (Free Templates Library, Live Copy, Animations, Post Grid, Post Carousel, Particles, Sliders, Chart, Blog, Video Gallery) plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.6.1. This is due to missing or incorrect nonce validation on the save_options() function. This makes it possible for unauthenticated attackers to update arbitrary options on the WordPress site via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Please note this is limited to option values that can be saved as arrays.
Published: 2024-11-22T05:33:41.092Z
Updated: 2026-04-08T16:55:24.054Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-11104 vulnerable 2026-06-08 06:23:48.754204 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.