Approved changes feed: RSS · Atom

cpe:2.3:a:wealcoder:animation_addons_for_elementor_–_gsap_motion_elementor_addons_&_website_templates:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorWealcoder (1b772001-c1ec-55a3-afa8-5b24eba1f2a8)
ProductAnimation Addons For Elementor – Gsap Motion Elementor Addons & Website Templates (68f52618-645c-5a49-a97e-e695f98150d4)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-15299 vulnerable 2026-07-29 00:26:17.979312 Animation Addons for Elementor <= 2.6.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Weather Widget
MEDIUM (6.4)
The Animation Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'weather_style' and 'move_direction' parameters of the Weather widget in all versions up to, and including, 2.6.3. This is due to insufficient output escaping in the Weather widget's render() function at widgets/weather.php:1246, where both settings values are placed into an HTML class attribute without esc_attr(). Elementor does not server-side validate widget SELECT control values against allowed options on save, so an authenticated attacker with Contributor-level access or above can submit a crafted save_builder AJAX request storing arbitrary values in the _elementor_data post meta. The stored payload renders unescaped on every frontend visit to the affected page (the Weather widget requires an OpenWeatherMap API key to reach the vulnerable output, which is the normal operational state for sites using this widget).
Published: 2026-07-10T04:31:27.184Z
Updated: 2026-07-10T13:16:15.917Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-8444 vulnerable 2026-07-29 00:18:11.025555 Animation Addons for Elementor – GSAP Powered Elementor Addons & Website Templates <= 4.2.6 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting via Multiple Parameters
MEDIUM (6.4)
The Animation Addons for Elementor – GSAP Powered Elementor Addons & Website Templates plugin for WordPress is vulnerable to DOM-Based Stored Cross-Site Scripting via the multiple parameters in all versions up to, and including, 4.2.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-06-10T04:31:00.888Z
Updated: 2026-10-30T17:34:11.183Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-12340 vulnerable 2026-06-08 06:23:51.737524 Animation Addons for Elementor <= 1.1.6 - Authenticated (Contributor+) Sensitive Information Exposure via Content Slider and Tabs Widget Elementor Template
MEDIUM (4.3)
The Animation Addons for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.1.6 via the 'render' function in widgets/content-slider.php and widgets/tabs.php. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive private, pending, and draft Elementor template data.
Published: 2024-12-18T09:22:38.826Z
Updated: 2026-04-08T16:37:58.072Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.