Approved changes feed: RSS · Atom

cpe:2.3:a:virgial:bootstrap_blocks_for_wp_editor_v2:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorVirgial (3e7dbe19-76a9-5f0e-a744-5bbc2ea08a79)
ProductBootstrap Blocks For Wp Editor V2 (9d1cf0e1-2df0-5f49-9210-0aa2afa70a30)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-12495 vulnerable 2026-06-08 06:25:35.394734 Bootstrap Blocks for WP Editor v2 <= 2.5.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
MEDIUM (6.4)
The Bootstrap Blocks for WP Editor v2 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'gtb-bootstrap/column' block in all versions up to, and including, 2.5.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-01-07T06:40:58.027Z
Updated: 2026-04-08T16:51:47.415Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.