Approved changes feed: RSS · Atom

cpe:2.3:a:solid_plugins:analyticswp:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorSolid Plugins (b0715f71-2784-51f4-b9a8-3a6866ccc00d)
ProductAnalyticswp (0d38659b-6275-570f-ab09-acbeee2e8d39)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-39394 vulnerable 2026-06-08 07:23:06.498781 WordPress AnalyticsWP plugin <= 2.1.2 - Sensitive Data Exposure vulnerability
MEDIUM (5.3)
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in Solid Plugins AnalyticsWP allows Retrieve Embedded Sensitive Data.This issue affects AnalyticsWP: from n/a through 2.1.2.
Published: 2025-05-19T16:51:13.144Z
Updated: 2026-04-28T16:12:30.306Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-39389 vulnerable 2026-06-08 07:23:06.493883 WordPress AnalyticsWP <= 2.1.2 - SQL Injection Vulnerability
CRITICAL (9.3)
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Solid Plugins AnalyticsWP allows SQL Injection.This issue affects AnalyticsWP: from n/a through 2.1.2.
Published: 2025-05-19T19:31:20.579Z
Updated: 2026-04-28T16:12:30.242Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-39388 vulnerable 2026-06-08 07:23:06.493516 WordPress AnalyticsWP plugin <= 2.0.0 - Broken Access Control vulnerability
MEDIUM (5.3)
Missing Authorization vulnerability in Solid Plugins AnalyticsWP allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects AnalyticsWP: from n/a through 2.0.0.
Published: 2025-05-19T16:47:44.841Z
Updated: 2026-04-28T16:12:30.167Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-13321 vulnerable 2026-06-08 06:25:37.273278 AnalyticsWP <= 2.0.0 - Unauthenticated SQL Injection
HIGH (7.5)
The AnalyticsWP plugin for WordPress is vulnerable to SQL Injection via the 'custom_sql' parameter in all versions up to, and including, 2.0.0 due to insufficient authorization checks on the handle_get_stats() function. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Published: 2025-03-14T07:23:20.937Z
Updated: 2026-04-08T17:33:31.891Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.