Approved changes feed: RSS · Atom

cpe:2.3:a:websoudan:mw_wp_form:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorWebsoudan (bd6c97cb-05c4-534a-a3fa-805cc3bbc817)
ProductMw Wp Form (0861a59e-b97c-507a-92c0-e4010cce0708)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-92086 vulnerable 2026-11-03 10:16:21.439164 MW WP Form <= 5.1.7 - Unauthenticated Sensitive Information Exposure in 'post_id' Parameter
MEDIUM (5.3)
The MW WP Form plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 5.1.7 via the 'post_id' parameter. This makes it possible for unauthenticated attackers to extract personally identifiable information from other users' form inquiry records, including submitted names, email addresses, and free-text message bodies, by enumerating sequential post IDs. Exploitation requires the targeted form to have the querystring setting enabled, but this is a standard documented feature of the plugin.
Published: 2026-10-29T11:27:15.236Z
Updated: 2026-10-29T12:36:50.947Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2026-8853 vulnerable 2026-07-29 01:09:06.330013 MW WP Form <= 5.1.3 - Authenticated (Editor+) Stored Cross-Site Scripting via 'memo' Parameter
MEDIUM (4.4)
The MW WP Form plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'memo' parameter in all versions up to, and including, 5.1.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with editor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Because the memo value is stored via update_post_meta() rather than wp_insert_post(), WordPress's built-in kses and unfiltered_html protections do not apply, allowing attackers to break out of the textarea element via injected closing tags regardless of role-based content filtering.
Published: 2026-06-10T07:50:55.322Z
Updated: 2026-06-10T12:56:19.273Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2026-6206 vulnerable 2026-06-08 08:07:04.548382 MW WP Form <= 5.1.2 - Insecure Direct Object Reference to Unauthenticated Sensitive Information Disclosure via 'post_id' Query Parameter
MEDIUM (5.3)
The MW WP Form plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 5.1.2 via the _get_post_property_from_querystring() function due to insufficient restrictions on which posts can be included. This makes it possible for unauthenticated attackers to extract data from password protected, private, or draft posts that they should not have access to.
Published: 2026-05-14T08:24:26.532Z
Updated: 2026-05-14T10:42:52.973Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-24804 vulnerable 2026-06-08 06:29:41.801925 WordPress MW WP Form Plugin <= 5.0.6 is vulnerable to Cross Site Scripting (XSS)
MEDIUM (6.5)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in websoudan MW WP Form allows Stored XSS.This issue affects MW WP Form: from n/a through 5.0.6.
Published: 2024-02-10T07:45:51.290Z
Updated: 2026-04-28T16:09:10.656Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.