Approved changes feed: RSS · Atom
cpe:2.3:a:zenmlio:zenml:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Zenmlio (1f5a37f2-9dfc-539e-8878-1adda52e99cf) |
|---|---|
| Product | Zenml (336b5b8a-288b-5ca0-bb62-efd7ec29e327) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2024-5062 |
vulnerable | 2026-06-08 06:56:14.758002 |
Reflected XSS through survey redirect parameter in zenml-io/zenml
MEDIUM (5.3)
A reflected Cross-Site Scripting (XSS) vulnerability was identified in zenml-io/zenml version 0.57.1. The vulnerability exists due to improper neutralization of input during web page generation, specifically within the survey redirect parameter. This flaw allows an attacker to redirect users to a specified URL after completing a survey, without proper validation of the 'redirect' parameter. Consequently, an attacker can execute arbitrary JavaScript code in the context of the user's browser session. This vulnerability could be exploited to steal cookies, potentially leading to account takeover.
Published: 2024-06-30T15:14:25.313Z
Updated: 2024-08-01T21:03:10.618Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-4311 |
vulnerable | 2026-06-08 06:50:17.480616 |
Lack of login attempt rate-limiting in zenml-io/zenml
MEDIUM (5.4)
zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.
Published: 2024-11-14T17:35:53.703Z
Updated: 2024-11-18T15:40:16.154Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-2260 |
vulnerable | 2026-06-08 06:33:30.721605 |
Session Fixation Vulnerability in zenml-io/zenml
MEDIUM (4.2)
A session fixation vulnerability exists in the zenml-io/zenml application, where JWT tokens used for user authentication are not invalidated upon logout. This flaw allows an attacker to bypass authentication mechanisms by reusing a victim's JWT token.
Published: 2024-04-16T00:00:14.951Z
Updated: 2024-08-01T19:03:39.351Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-2213 |
vulnerable | 2026-06-08 06:33:30.627713 |
Improper Authentication in zenml-io/zenml
LOW (3.3)
An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.
Published: 2024-06-06T18:19:26.553Z
Updated: 2025-10-21T14:14:02.198Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-2171 |
vulnerable | 2026-06-08 06:33:30.471329 |
Stored XSS in zenml-io/zenml
LOW (3.4)
A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.
Published: 2024-06-06T18:22:31.301Z
Updated: 2024-08-09T18:41:46.790Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-2083 |
vulnerable | 2026-06-08 06:33:30.309470 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-2035 |
vulnerable | 2026-06-08 06:33:30.181439 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-25723 |
vulnerable | 2026-06-08 06:31:23.794676 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.