Approved changes feed: RSS · Atom

cpe:2.3:a:idioweb:extensions_for_elementor:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorIdioweb (adb87430-9d98-5b95-a4eb-5be40cacb0ec)
ProductExtensions For Elementor (53688e5f-ab33-5207-8ff4-e6d9f25211b0)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-5666 vulnerable 2026-06-08 06:56:16.978094 Extensions for Elementor <= 2.0.30 - Authenticated (Contributor+) Stored Cross-Site Scripting via url Parameter
MEDIUM (6.4)
The Extensions for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘url’ parameter within the EE Button widget in all versions up to, and including, 2.0.30 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-06-29T07:05:38.149Z
Updated: 2026-04-08T16:57:15.736Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-52471 vulnerable 2026-06-08 06:52:15.243213 WordPress Extensions for Elementor plugin <= 2.0.37 - Reflected Cross Site Scripting (XSS) vulnerability
HIGH (7.1)
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in petesheppard84 Extensions for Elementor allows Reflected XSS.This issue affects Extensions for Elementor: from n/a through 2.0.37.
Published: 2024-11-20T14:32:54.916Z
Updated: 2026-04-28T16:10:43.111Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-4868 vulnerable 2026-06-08 06:50:18.820742 Extensions for Elementor <= 2.0.32 - Authenticated (Contributor+) Stored Cross-Site Scripting via EE Events and EE Flipbox Widget
MEDIUM (6.4)
The Extensions for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's EE Events and EE Flipbox widgets in all versions up to, and including, 2.0.32 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-07-09T08:33:05.244Z
Updated: 2026-04-08T16:49:03.823Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-39668 vulnerable 2026-06-08 06:41:51.318687 WordPress Extensions for Elementor plugin <= 2.0.31 - Cross Site Scripting (XSS) vulnerability
MEDIUM (6.5)
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in petesheppard84 Extensions for Elementor allows Stored XSS.This issue affects Extensions for Elementor: from n/a through 2.0.31.
Published: 2024-08-01T21:31:07.381Z
Updated: 2026-04-28T16:10:08.422Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.