Ba Book Everything
Approved changes feed: RSS · Atom
cpe:2.3:a:bookingalgorithms:ba_book_everything:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Bookingalgorithms (d273cb56-ed6c-5d04-8466-69ad1133218a) |
|---|---|
| Product | Ba Book Everything (31206e23-eb8d-53b6-a9f0-2fe90ed1fe35) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-24371 |
vulnerable | 2026-06-08 07:51:17.603783 |
WordPress BA Book Everything plugin <= 1.8.16 - Broken Access Control vulnerability
MEDIUM (4.3)
Missing Authorization vulnerability in bookingalgorithms BA Book Everything ba-book-everything allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects BA Book Everything: from n/a through <= 1.8.16.
Published: 2026-01-22T16:52:45.641Z
Updated: 2026-04-28T16:14:47.894Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-14449 |
vulnerable | 2026-06-08 07:06:34.508187 |
BA Book Everything <= 1.8.14 - Authenticated (Contributor+) Stored Cross-Site Scripting via babe-search-form Shortcode
MEDIUM (6.4)
The BA Book Everything plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's babe-search-form shortcode in all versions up to, and including, 1.8.14 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-12-19T06:48:22.992Z
Updated: 2026-04-08T16:43:45.109Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-8795 |
vulnerable | 2026-06-08 07:00:25.740622 |
BA Book Everything <= 1.6.20 - Cross-Site Request Forgery to Email Address Update/Account Takeover
HIGH (8.8)
The BA Book Everything plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.6.20. This is due to missing or incorrect nonce validation on the my_account_update() function. This makes it possible for unauthenticated attackers to update a user's account details via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This can be leveraged to reset a user's password and gain access to their account.
Published: 2024-09-24T01:56:47.005Z
Updated: 2026-04-08T17:17:27.796Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-8794 |
vulnerable | 2026-06-08 07:00:25.739442 |
BA Book Everything <= 1.6.20 - Unauthenticated Arbitrary User Password Reset
MEDIUM (5.3)
The BA Book Everything plugin for WordPress is vulnerable to arbitrary password reset in all versions up to, and including, 1.6.20. This is due to the reset_user_password() function not verifying a user's identity prior to setting a password. This makes it possible for unauthenticated attackers to reset any user's passwords, including administrators. It's important to note that the attacker will not have access to the generated password, therefore, privilege escalation is not possible.
Published: 2024-09-24T02:31:01.384Z
Updated: 2026-04-08T16:51:40.832Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-47360 |
vulnerable | 2026-06-08 06:48:11.846144 |
WordPress BA Book Everything plugin <= 1.6.20 - Reflected Cross Site Scripting (XSS) vulnerability
HIGH (7.1)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bookingalgorithms BA Book Everything ba-book-everything.This issue affects BA Book Everything: from n/a through <= 1.6.20.
Published: 2024-10-06T09:52:17.278Z
Updated: 2026-04-28T16:10:19.544Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-3672 |
vulnerable | 2026-06-08 06:43:51.172169 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.