Wp Staging Pro Wordpress Backup Plugin
Approved changes feed: RSS · Atom
cpe:2.3:a:wpstaging:wp_staging_pro_wordpress_backup_plugin:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Wpstaging (816bb65b-c9b7-57ad-a58d-7537ed3a92e7) |
|---|---|
| Product | Wp Staging Pro Wordpress Backup Plugin (fb4dce24-c69e-5a44-ab0d-87eba3eda46a) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2025-3104 |
vulnerable | 2026-06-08 07:23:08.116876 |
WP Staging Pro <= 6.1.2 - Unauthenticated Information Exposure via getOutdatedPluginsRequest Function
MEDIUM (5.3)
The WP STAGING Pro WordPress Backup Plugin for WordPress is vulnerable to Information Exposure in all versions up to and including 6.1.2 due to missing capability checks on the getOutdatedPluginsRequest() function. This makes it possible for unauthenticated attackers to reveal outdated installed active or inactive plugins.
Published: 2025-04-16T08:22:17.436Z
Updated: 2026-04-08T16:54:18.717Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-5551 |
vulnerable | 2026-06-08 06:56:16.523559 |
WP STAGING PRO - Backup Duplicator & Migration <= 5.6.0 - Cross-Site Request Forgery to Limited Local File Inclusion
HIGH (7.5)
The WP STAGING Pro WordPress Backup Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.6.0. This is due to missing or incorrect nonce validation on the 'sub' parameter called from the WP STAGING WordPress Backup Plugin - Backup Duplicator & Migration plugin. This makes it possible for unauthenticated attackers to include any local files that end in '-settings.php' via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2024-06-14T05:39:14.293Z
Updated: 2026-04-08T16:43:31.792Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-3682 |
vulnerable | 2026-06-08 06:43:51.208363 |
WP STAGING <= 3.4.3 and WP STAGING Pro <= 5.4.3 - Sensitive Information Exposure via Log File
MEDIUM (5.3)
The WP STAGING and WP STAGING Pro plugins for WordPress are vulnerable to Sensitive Information Exposure in versions up to, and including, 3.4.3, and versions up to, and including, 5.4.3, respectively, via the ajaxSendReport function. This makes it possible for unauthenticated attackers to extract sensitive data from a log file, including system information and (in the Pro version) license keys. Successful exploitation requires an administrator to have used the 'Contact Us' functionality along with the "Enable this option to automatically submit the log files." option.
Published: 2024-04-26T09:29:51.745Z
Updated: 2026-04-08T17:01:25.475Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.