Authenticator
Approved changes feed: RSS · Atom
cpe:2.3:a:authenticator-extension:authenticator:*:*:*:*:*:*:*:*
part: a version: * update: *
| Vendor | Authenticator Extension (ba360366-8a46-5c19-b451-2c214a7cb6c9) |
|---|---|
| Product | Authenticator (8534a73a-c3e1-5cde-b9ab-151161f30367) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
| Notes | Imported from gcve-enriched-dumps CVE data |
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2024-45394 |
vulnerable | 2026-06-08 06:48:06.049078 |
Secret encryption vulnerable to brute-force attacks
HIGH (8.8)
Authenticator is a browser extension that generates two-step verification codes. In versions 7.0.0 and below, encryption keys for user data were stored encrypted at-rest using only AES-256 and the EVP_BytesToKey KDF. Therefore, attackers with a copy of a user's data are able to brute-force the user's encryption key. Users on version 8.0.0 and above are automatically migrated away from the weak encoding on first login. Users should destroy encrypted backups made with versions prior to 8.0.0.
Published: 2024-09-03T20:15:42.769Z
Updated: 2024-10-09T14:27:06.537Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.