Wpcom Member
Approved changes feed: RSS · Atom
cpe:2.3:a:wpcom:wpcom_member:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Wpcom (03b7929f-4ae3-5780-8ba8-a9fab0d09de6) |
|---|---|
| Product | Wpcom Member (34bce13b-8106-598e-ada3-dbfb33659f4a) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2025-2221 |
vulnerable | 2026-06-08 07:16:56.506261 |
WPCOM Member <= 1.7.6 - Unauthenticated Time-Based SQL Injection
HIGH (7.5)
The WPCOM Member plugin for WordPress is vulnerable to time-based SQL Injection via the ‘user_phone’ parameter in all versions up to, and including, 1.7.6 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Published: 2025-03-14T06:43:17.622Z
Updated: 2026-04-08T17:06:31.266Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-7493 |
vulnerable | 2026-06-08 06:58:22.294190 |
WPCOM Member <= 1.5.2.1 - Unauthenticated Privilege Escalation via User Meta
CRITICAL (9.8)
The WPCOM Member plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 1.5.2.1. This is due to the plugin allowing arbitrary data to be passed to wp_insert_user() during registration. This makes it possible for unauthenticated attackers to update their role to that of an administrator during registration.
Published: 2024-09-06T13:55:20.451Z
Updated: 2026-04-08T17:31:25.115Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-47378 |
vulnerable | 2026-06-08 06:48:11.881636 |
WordPress WPCOM Member plugin <= 1.5.4 - Reflected Cross Site Scripting (XSS) vulnerability
HIGH (7.1)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Lomu WPCOM Member wpcom-member allows Reflected XSS.This issue affects WPCOM Member: from n/a through <= 1.5.4.
Published: 2024-10-05T15:10:27.765Z
Updated: 2026-04-28T16:10:20.021Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.