Approved changes feed: RSS · Atom

cpe:2.3:a:async-graphql:async-graphql:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorAsync Graphql (e682b6f7-c35e-5cff-b689-ae73dfaf23b9)
ProductAsync Graphql (11664598-53a1-55ae-9e7a-f918456beaaf)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-47614 vulnerable 2026-06-08 06:48:12.941359 async-graphql vulnerable to Directive Overload
HIGH (7.5)
async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10.
Published: 2024-10-03T14:29:59.124Z
Updated: 2024-10-03T15:47:22.144Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.