Approved changes feed: RSS · Atom

cpe:2.3:a:bdevs:generic_elements:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorBdevs (f894e649-0451-596e-90e0-bfc64bf4c169)
ProductGeneric Elements (e66b7f7c-900d-5685-b799-4e5fb93a505a)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-9080 vulnerable 2026-06-08 07:45:21.664445 Generic Elements <= 1.2.8 - Authenticated (Contributor+) Stored Cross-Site Scripting
MEDIUM (6.4)
The Generic Elements plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple widget fields in version 1.2.8 and earlier. This is due to insufficient input sanitization and output escaping on user-supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-10-03T11:17:14.730Z
Updated: 2026-04-08T17:02:18.437Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-53709 vulnerable 2026-06-08 06:54:15.390786 WordPress Generic Elements plugin <= 1.2.5 - Cross Site Scripting (XSS) vulnerability
MEDIUM (6.5)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nasir Uddin Generic Elements generic-elements-for-elementor allows DOM-Based XSS.This issue affects Generic Elements: from n/a through <= 1.2.5.
Published: 2024-12-02T13:48:49.874Z
Updated: 2026-04-28T16:10:44.107Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.