Armember Premium – Membership Plugin, Content Restriction, Member Levels, User Profile & User Signup
Approved changes feed: RSS · Atom
cpe:2.3:a:armember:armember_premium_–_membership_plugin,_content_restriction,_member_levels,_user_profile_&_user_signup:*:*:*:*:*:*:*:*
part: a version: * update: *
| Vendor | Armember (2db8efdd-9e0b-58e2-9c19-a01d8350d9c6) |
|---|---|
| Product | Armember Premium – Membership Plugin, Content Restriction, Member Levels, User Profile & User Signup (1309d1f1-e059-552e-be62-d8c5ff1a7c6f) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
| Notes | Imported from gcve-enriched-dumps CVE data |
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-5076 |
vulnerable | 2026-06-08 08:07:02.964945 |
ARMember Premium <= 7.3.1 - Insecure Password Reset Mechanism to Unauthenticated Privilege Escalation
CRITICAL (9.8)
The ARMember Premium plugin for WordPress is vulnerable to an insecure password reset mechanism in all versions up to, and including, 7.3.1. The plugin stores a plaintext copy of the password reset key in the `arm_reset_password_key` user meta field when a user requests a password reset. This is in addition to the hashed key that WordPress core stores securely in `wp_users.user_activation_key`. The plaintext key stored in `wp_usermeta` can be used with the plugin's custom `armrp` reset action to set a new password for any user. Combined with another vulnerability such as SQL Injection (CVE-2026-5073, CVE-2026-5074), this makes it possible for unauthenticated attackers to extract the plaintext reset key and take over any user account, including administrators.
Published: 2026-06-02T18:30:46.269Z
Updated: 2026-06-02T20:56:08.662Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-5074 |
vulnerable | 2026-06-08 08:07:02.962054 |
ARMember Premium <= 7.3.1 - Authenticated (Subscriber+) SQL Injection via 'sSortDir_0' Parameter
MEDIUM (6.5)
The ARMember Premium plugin for WordPress is vulnerable to SQL Injection via the 'sSortDir_0' parameter of the `get_private_content_data` AJAX action in all versions up to, and including, 7.3.1. This is due to insufficient sanitization of the user-supplied parameter which is concatenated directly into the ORDER BY clause of an SQL query without a whitelist check. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Note: The vulnerability can only be exploited if the "User Private Content" addon is enabled, which is disabled by default..
Published: 2026-06-02T18:30:46.862Z
Updated: 2026-06-02T20:55:53.439Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-5073 |
vulnerable | 2026-06-08 08:07:02.961607 |
ARMember Premium <= 7.3.1 - Unauthenticated SQL Injection via 'order' Parameter
HIGH (7.5)
The ARMember Premium plugin for WordPress is vulnerable to SQL Injection via the 'order' parameter of the 'arm_directory_paging_action' AJAX action in all versions up to, and including, 7.3.1. This is due to insufficient escaping on the user-supplied 'order' and 'orderby' parameters and the lack of sufficient preparation on the existing SQL query in the `arm_get_directory_members()` function. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Published: 2026-06-02T18:30:47.226Z
Updated: 2026-06-02T20:55:39.866Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-5596 |
vulnerable | 2026-06-08 06:56:16.645169 |
ARMember Premium <= 6.7 - Cross-Site Request Forgery via multiple functions
MEDIUM (6.3)
The ARMember Premium plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 6.7. This is due to incorrectly implemented nonce validation function on multiple functions. This makes it possible for unauthenticated attackers to modify, or delete user meta and plugin options which can lead to limited privilege escalation.
Published: 2024-06-22T05:47:55.999Z
Updated: 2026-04-08T16:47:51.555Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.