Approved changes feed: RSS · Atom

cpe:2.3:a:ataurr:gutenkit_–_page_builder_blocks,_patterns,_and_templates_for_gutenberg_block_editor:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorAtaurr (0192fd19-815c-54e3-ae91-b519a779ce13)
ProductGutenkit – Page Builder Blocks, Patterns, And Templates For Gutenberg Block Editor (384199f5-0525-55dd-95e0-197ddc2e70d6)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-15827 vulnerable 2026-07-29 00:26:18.480715 GutenKit <= 2.4.12 - Missing Authorization to Unauthenticated Sensitive Information Exposure via Mailchimp REST Endpoints
MEDIUM (5.3)
The GutenKit Blocks plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the /wp-json/gutenkit/v1/mailchimp/get/lists and /wp-json/gutenkit/v1/mailchimp/get/interests REST API endpoints in versions up to, and including, 2.4.12. Both endpoints are registered with permission_callback => '__return_true', and their callbacks read the site's stored Mailchimp API key from the gutenkit_settings_list option and proxy Mailchimp audience/list, merge-field, interest-category, interest-name, and subscriber-count metadata back to the caller with no login, nonce, or capability check. This makes it possible for unauthenticated attackers to retrieve private Mailchimp audience configuration information from any site that has configured the GutenKit Mailchimp integration.
Published: 2026-07-23T08:34:39.337Z
Updated: 2026-07-23T13:53:00.860Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-9234 vulnerable 2026-06-08 07:00:26.980907 GutenKit <= 2.1.0 - Unauthenticated Arbitrary File Upload
CRITICAL (9.8)
The GutenKit – Page Builder Blocks, Patterns, and Templates for Gutenberg Block Editor plugin for WordPress is vulnerable to arbitrary file uploads due to a missing capability check on the install_and_activate_plugin_from_external() function (install-active-plugin REST API endpoint) in all versions up to, and including, 2.1.0. This makes it possible for unauthenticated attackers to install and activate arbitrary plugins, or utilize the functionality to upload arbitrary files spoofed like plugins.
Published: 2024-10-11T06:50:20.255Z
Updated: 2026-04-08T17:29:33.133Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.