Aruba Hispeed Cache
Approved changes feed: RSS · Atom
cpe:2.3:a:arubadev:aruba_hispeed_cache:*:*:*:*:*:*:*:*
part: a version: * update: *
| Vendor | Arubadev (9fa8523f-41d7-55c4-9b57-115feb81850e) |
|---|---|
| Product | Aruba Hispeed Cache (62eb20b6-676a-54e1-bf62-ffd3927268da) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
| Notes | Imported from gcve-enriched-dumps CVE data |
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-15889 |
vulnerable | 2026-09-16 04:33:06.602514 |
Aruba HiSpeed Cache <= 3.0.14 - Authenticated (Contributor+) Stored Cross-Site Scripting via Post Content
MEDIUM (6.4)
The Aruba HiSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Post Content in all versions up to, and including, 3.0.14 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-09-10T09:27:09.235Z
Updated: 2026-09-10T21:00:26.213Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-1924 |
vulnerable | 2026-06-08 07:49:09.857574 |
Aruba HiSpeed Cache <= 3.0.4 - Cross-Site Request Forgery to Plugin Settings Reset
MEDIUM (4.3)
The Aruba HiSpeed Cache plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.0.4. This is due to missing nonce verification on the `ahsc_ajax_reset_options()` function. This makes it possible for unauthenticated attackers to reset all plugin settings to their default values via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2026-04-10T01:24:59.928Z
Updated: 2026-04-10T12:18:06.324Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-11725 |
vulnerable | 2026-06-08 07:04:28.830308 |
Aruba HiSpeed Cache <= 3.0.2 - Missing Authorization to Unauthenticated Plugin's Settings Modification
MEDIUM (6.5)
The Aruba HiSpeed Cache plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability checks on the multiple functions in all versions up to, and including, 3.0.2. This makes it possible for unauthenticated attackers to modify plugin's configuration settings, enable or disable features, as well as enable/disable WordPress cron jobs or debug mode
Published: 2026-02-19T03:25:11.535Z
Updated: 2026-04-08T16:43:04.598Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-11706 |
vulnerable | 2026-06-08 07:04:28.793327 |
Aruba HiSpeed Cache <= 3.0.2 - Reflected Cross-Site Scripting
MEDIUM (6.1)
The Aruba HiSpeed Cache plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the dbstatus parameter in all versions up to, and including, 3.0.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Published: 2026-02-19T03:25:12.460Z
Updated: 2026-04-08T16:47:39.702Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.