Approved changes feed: RSS · Atom

cpe:2.3:a:wpfanyi:wpsite_shortcode:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorWpfanyi (fa8a3e3a-4557-5b37-934c-9b6cfc836147)
ProductWpsite Shortcode (c0619e46-924a-518e-a4c9-92b4e95da42a)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-11803 vulnerable 2026-06-08 07:04:28.968531 WPSite Shortcode <= 1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
MEDIUM (6.4)
The WPSite Shortcode plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'format' shortcode attribute in the wpsite_y shortcode and the 'before' attribute in the wpsite_postauthor shortcode in all versions up to, and including, 1.2. This is due to insufficient input sanitization and output escaping in error messages. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-11-21T08:28:11.139Z
Updated: 2026-04-08T16:35:17.464Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.