Approved changes feed: RSS · Atom

cpe:2.3:a:mxp:xx2wp_integration_tools:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorMxp (c200ac24-0d56-5b20-86a3-163daf4a9412)
ProductXx2Wp Integration Tools (cd3a39ea-7f5d-52b8-a1f0-2e87da816c23)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-11857 vulnerable 2026-06-08 07:04:29.317298 XX2WP Integration Tools <= 1.9.9 - Authenticated (Contributor+) Stored Cross-Site Scripting
MEDIUM (6.4)
The XX2WP Integration Tools plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'mxp_fb2wp_display_embed' shortcode in all versions up to, and including, 1.9.9. This is due to the plugin not properly sanitizing user input and output of the 'post_id' parameter. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-10-18T05:41:56.057Z
Updated: 2026-04-08T16:55:39.687Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.