Approved changes feed: RSS · Atom
cpe:2.3:a:wofssl:wolfssl:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Wofssl (0f2a3705-0834-5db0-b973-dddc881876d3) |
|---|---|
| Product | Wolfssl (031caec1-8877-5753-ba56-e882e304ed44) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-3549 |
vulnerable | 2026-06-08 08:01:18.954353 |
ECH parsing heap buffer overflow
Heap Overflow in TLS 1.3 ECH parsing. An integer underflow existed in ECH extension parsing logic when calculating a buffer length, which resulted in writing beyond the bounds of an allocated buffer. Note that in wolfSSL, ECH is off by default, and the ECH standard is still evolving.
Published: 2026-03-19T20:09:27.036Z
Updated: 2026-03-24T01:38:13.951Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-3229 |
vulnerable | 2026-06-08 08:01:18.247074 |
Integer Overflow in Certificate Chain Allocation
An integer overflow vulnerability existed in the static function wolfssl_add_to_chain, that caused heap corruption when certificate data was written out of bounds of an insufficiently sized certificate buffer. wolfssl_add_to_chain is called by these API: wolfSSL_CTX_add_extra_chain_cert, wolfSSL_CTX_add1_chain_cert, wolfSSL_add0_chain_cert. These API are enabled for 3rd party compatibility features: enable-opensslall, enable-opensslextra, enable-lighty, enable-stunnel, enable-nginx, enable-haproxy. This issue is not remotely exploitable, and would require that the application context loading certificates is compromised.
Published: 2026-03-19T21:07:05.871Z
Updated: 2026-03-20T16:29:47.729Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-11933 |
vulnerable | 2026-06-08 07:04:29.427181 |
DoS Vulnerability in wolfSSL TLS 1.3 CKS Extension
Improper Input Validation in the TLS 1.3 CKS extension parsing in wolfSSL 5.8.2 and earlier on multiple platforms allows a remote unauthenticated attacker to potentially cause a denial-of-service via a crafted ClientHello message with duplicate CKS extensions.
Published: 2025-11-21T22:19:08.654Z
Updated: 2025-12-08T15:47:25.494Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.