Approved changes feed: RSS · Atom

cpe:2.3:a:wpcommerz:twinklesmtp_–_email_service_provider_for_wordpress:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorWpcommerz (bb329d87-82a5-566a-8a16-40ead50e82c9)
ProductTwinklesmtp – Email Service Provider For Wordpress (f2352f8d-3ed7-5fca-995d-2242f4cddf2f)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-14887 vulnerable 2026-06-08 07:06:35.315665 twinklesmtp – Email Service Provider For WordPress <= 1.03 - Authenticated (Administrator+) Stored Cross-Site Scripting via Sender Settings
MEDIUM (4.4)
The twinklesmtp – Email Service Provider For WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via plugin's sender settings in all versions up to, and including, 1.03 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Published: 2026-01-07T06:35:59.164Z
Updated: 2026-04-08T16:41:37.407Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.