Approved changes feed: RSS · Atom

cpe:2.3:a:brian_messenlehner:wp-announcements:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorBrian Messenlehner (b765b7cc-ef45-5dfb-99b2-d4e91255e2e7)
ProductWp Announcements (9ae8ac7b-76ba-5bbe-86eb-0b70aba2bbd9)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-23489 vulnerable 2026-06-08 07:10:55.851045 WordPress WP-Announcements plugin <= 1.8 - Reflected Cross Site Scripting (XSS) vulnerability
HIGH (7.1)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brian Messenlehner WP-Announcements wp-announcements allows Reflected XSS.This issue affects WP-Announcements: from n/a through <= 1.8.
Published: 2025-01-21T17:21:50.160Z
Updated: 2026-04-28T16:11:10.695Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.