Approved changes feed: RSS · Atom

cpe:2.3:a:youki-dev:youki:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorYouki Dev (7927cd5e-3eb8-52d7-a751-c4fe8392347d)
ProductYouki (77ff4225-fa7d-5b4c-87fd-73578dc71320)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
pkg:github/youki-dev/youki purl2cpe 2026-07-28 16:41:12.848447

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-62596 vulnerable 2026-06-08 07:39:16.162835 youki container escape and denial of service due to arbitrary write gadgets and procfs write redirects
Youki is a container runtime written in Rust. In versions 0.5.6 and below, youki’s apparmor handling performs insufficiently strict write-target validation, and when combined with path substitution during pathname resolution, can allow writes to unintended procfs locations. While resolving a path component-by-component, a shared-mount race can substitute intermediate components and redirect the final target. This issue is fixed in version 0.5.7.
Published: 2025-11-05T23:14:37.167Z
Updated: 2025-11-06T16:54:15.942Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-62161 vulnerable 2026-06-08 07:37:28.725494 youki container escape via "masked path" abuse due to mount race conditions
Youki is a container runtime written in Rust. In versions 0.5.6 and below, the initial validation of the source /dev/null is insufficient, allowing container escape when youki utilizes bind mounting the container's /dev/null as a file mask. This issue is fixed in version 0.5.7.
Published: 2025-11-05T23:09:09.014Z
Updated: 2025-11-06T21:20:19.865Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-54867 vulnerable 2026-06-08 07:33:13.503869 Youki Symlink Following Vulnerability
HIGH (7)
Youki is a container runtime written in Rust. Prior to version 0.5.5, if /proc and /sys in the rootfs are symbolic links, they can potentially be exploited to gain access to the host root filesystem. This issue has been patched in version 0.5.5.
Published: 2025-08-14T16:08:00.622Z
Updated: 2025-08-14T19:26:11.541Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-27612 vulnerable 2026-06-08 07:14:55.372618 Libcontainer is affected by capabilities elevation
MEDIUM (5.9)
libcontainer is a library for container control. Prior to libcontainer 0.5.3, while creating a tenant container, the tenant builder accepts a list of capabilities to be added in the spec of tenant container. The logic here adds the given capabilities to all capabilities of main container if present in spec, otherwise simply set provided capabilities as capabilities of the tenant container. However, setting inherited caps in any case for tenant container can lead to elevation of capabilities, similar to CVE-2022-29162. This does not affect youki binary itself. This is only applicable if you are using libcontainer directly and using the tenant builder.
Published: 2025-03-21T14:24:28.756Z
Updated: 2025-03-21T15:20:00.538Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.