Approved changes feed: RSS · Atom

cpe:2.3:a:ultimate_blocks:ultimate_blocks:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorUltimate Blocks (ae6c5f5a-0fc2-5572-8ec6-29462f7d6224)
ProductUltimate Blocks (238fa3e0-d367-5103-848e-2a01f945fa60)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-49929 vulnerable 2026-06-08 07:29:15.119531 WordPress Ultimate Blocks plugin <= 3.3.6 - Cross Site Scripting (XSS) vulnerability
MEDIUM (6.5)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ultimate Blocks Ultimate Blocks ultimate-blocks allows Stored XSS.This issue affects Ultimate Blocks: from n/a through <= 3.3.6.
Published: 2025-10-22T14:32:14.811Z
Updated: 2026-04-28T20:25:12.288Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-48234 vulnerable 2026-06-08 07:27:15.584342 WordPress Ultimate Blocks plugin <= 3.3.0 - Cross Site Scripting (XSS) Vulnerability
MEDIUM (6.5)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ultimate Blocks Ultimate Blocks ultimate-blocks allows DOM-Based XSS.This issue affects Ultimate Blocks: from n/a through <= 3.3.0.
Published: 2025-05-19T14:44:50.310Z
Updated: 2026-04-28T16:12:53.355Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-47493 vulnerable 2026-06-08 07:27:14.468329 WordPress Ultimate Blocks plugin <= 3.2.9 - Cross Site Scripting (XSS) Vulnerability
MEDIUM (6.5)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ultimate Blocks Ultimate Blocks ultimate-blocks allows DOM-Based XSS.This issue affects Ultimate Blocks: from n/a through <= 3.2.9.
Published: 2025-05-07T14:19:53.136Z
Updated: 2026-04-28T16:12:42.766Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-31077 vulnerable 2026-06-08 07:17:02.328212 WordPress Ultimate Blocks plugin <= 3.2.7 - Cross Site Scripting (XSS) vulnerability
MEDIUM (6.5)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ultimate Blocks Ultimate Blocks ultimate-blocks allows DOM-Based XSS.This issue affects Ultimate Blocks: from n/a through <= 3.2.7.
Published: 2025-03-28T09:39:56.764Z
Updated: 2026-04-28T16:12:04.822Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.