Approved changes feed: RSS · Atom

cpe:2.3:a:thinkinai:deepchat:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorThinkinai (ce62f237-178d-50ff-9dd5-ab7da2e9fb0f)
ProductDeepchat (0f7739ad-d2e0-5dcf-a827-57cdf8e98a40)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
pkg:github/thinkinaixyz/deepchat purl2cpe 2026-07-28 16:41:17.457189

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-108852 vulnerable 2026-11-03 10:18:01.845999 Deep Chat through 2.5.1 XSS via Markdown Link Validation Bypass
MEDIUM (4.7)
Deep Chat through 2.5.1 contains a cross-site scripting vulnerability that allows attackers to inject javascript: links because RemarkableConfig.createNew disables Remarkable link validation. Attackers can place crafted Markdown links in AI responses, addMessage content, or loaded history to execute script in the embedding page when victims click them.
Published: 2026-10-11T13:26:02.055Z
Updated: 2026-10-13T16:59:47.203Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-67744 vulnerable 2026-06-08 07:41:20.397213 Mermaid XSS vulnerability leads to Remote Code Execution
CRITICAL (9.7)
DeepChat is an open-source artificial intelligence agent platform that unifies models, tools, and agents. Prior to version 0.5.3, a security vulnerability exists in the Mermaid diagram rendering component that allows arbitrary JavaScript execution. Due to the exposure of the Electron IPC renderer to the DOM, this Cross-Site Scripting (XSS) flaw escalates to full Remote Code Execution (RCE), allowing an attacker to execute arbitrary system commands. Two concurrent issues, unsafe Mermaid configuration and an exposed IPC interface, cause this issue. Version 0.5.3 contains a patch.
Published: 2025-12-16T00:42:21.256Z
Updated: 2025-12-16T21:08:19.864Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-66481 vulnerable 2026-06-08 07:41:19.012182 DeepChat's Incomplete XSS Fix Allows RCE through Mermaid Content
CRITICAL (9.7)
DeepChat is an open-source AI chat platform that supports cloud models and LLMs. Versions 0.5.1 and below are vulnerable to XSS attacks through improperly sanitized Mermaid content. The recent security patch for MermaidArtifact.vue is insufficient and can be bypassed using unquoted HTML attributes combined with HTML entity encoding. Remote Code Execution is possible on the victim's machine via the electron.ipcRenderer interface, bypassing the regex filter intended to strip dangerous attributes. There is no fix at time of publication.
Published: 2025-12-09T00:25:08.301Z
Updated: 2025-12-09T16:03:38.736Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-66222 vulnerable 2026-06-08 07:39:21.896655 DeepChat Cross-Site Scripting(XSS) escalate to Remote Code Execution(RCE)
CRITICAL (9.7)
DeepChat is a smart assistant uses artificial intelligence. In 0.5.0 and earlier, there is a Stored Cross-Site Scripting (XSS) vulnerability in the Mermaid diagram renderer allows an attacker to execute arbitrary JavaScript within the application context. By leveraging the exposed Electron IPC bridge, this XSS can be escalated to Remote Code Execution (RCE) by registering and starting a malicious MCP (Model Context Protocol) server.
Published: 2025-12-03T18:34:44.019Z
Updated: 2025-12-03T19:10:17.039Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-58768 vulnerable 2026-06-08 07:35:19.515050 DeepChat's Mermaid rendering has XSS leading to RCE
CRITICAL (9.7)
DeepChat is a smart assistant uses artificial intelligence. Prior to version 0.3.5, in the Mermaid chart rendering component, there is a risky operation of directly using `innerHTML` to set user content. Therefore, any malicious content rendered via Mermaid will directly trigger the exploit chain, leading to command execution. This vulnerability is primarily caused by a failure to fully address the existing XSS issue in the project, leading to another exploit chain. The exploit chain is consistent with the report GHSA-hqr4-4gfc-5p2j, executing arbitrary JavaScript code via XSS and arbitrary commands via exposed IPC. Version 0.3.5 contains an updated fix.
Published: 2025-09-09T20:19:52.122Z
Updated: 2025-09-09T20:31:54.042Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.