Approved changes feed: RSS · Atom

cpe:2.3:a:asaquzzaman:wp_human_resource_management:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorAsaquzzaman (9467bc18-9b0b-5c24-88f0-bef41e207b8e)
ProductWp Human Resource Management (3bf4f655-7de9-5e96-ad57-ad6bf79f3efe)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-5956 vulnerable 2026-06-08 07:37:26.140576 WP Human Resource Management 2.0.0 - 2.2.17 - Missing Authorization to Authenticated (Employee+) Arbitrary User Deletion via ajax_delete_employee Function
MEDIUM (6.5)
The WP Human Resource Management plugin for WordPress is vulnerable to Arbitrary User Deletion due to a missing authorization within the ajax_delete_employee() function in versions 2.0.0 through 2.2.17. The plugin’s deletion handler reads the client-supplied $_POST['delete'] array and passes each ID directly to wp_delete_user() without verifying that the caller has the delete_users capability or limiting which user IDs may be removed. This makes it possible for authenticated attackers, with Employee-level access and above, to delete arbitrary accounts, including administrators.
Published: 2025-07-04T01:44:02.706Z
Updated: 2025-07-08T14:27:12.158Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-5953 vulnerable 2026-06-08 07:37:26.131666 WP Human Resource Management 2.0.0 - 2.2.17 - Missing Authorization to Authenticated (Employee+) Privilege Escalation via wp_ajax_hrm_insert_employee AJAX Action
HIGH (8.8)
The WP Human Resource Management plugin for WordPress is vulnerable to Privilege Escalation due to missing authorization in the ajax_insert_employee() and update_empoyee() functions in versions 2.0.0 through 2.2.17. The AJAX handler reads the client-supplied $_POST['role'] and, after basic cleaning via hrm_clean(), passes it directly to wp_insert_user() and later to $user->set_role() without verifying that the current user is allowed to assign that role. This makes it possible for authenticated attackers, with Employee-level access and above, to elevate their privileges to administrator.
Published: 2025-07-04T01:44:03.834Z
Updated: 2025-07-08T14:21:48.349Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.