Approved changes feed: RSS · Atom

cpe:2.3:a:asfhtgkdavid:theshit:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorAsfhtgkdavid (3e9b9bf0-1c01-5513-b497-535a92b491a0)
ProductTheshit (afac8d58-8874-583c-9413-e3d0980d8b5a)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-21882 vulnerable 2026-06-08 07:49:16.940742 theshit's Improper Privilege Dropping Allows Local Privilege Escalation via Command Re-execution
HIGH (8.4)
theshit is a command-line utility that automatically detects and fixes common mistakes in shell commands. Prior to version 0.2.0, improper privilege dropping allows local privilege escalation via command re-execution. This issue has been patched in version 0.2.0.
Published: 2026-03-02T19:17:22.220Z
Updated: 2026-03-02T19:44:41.557Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-69257 vulnerable 2026-06-08 07:41:22.275317 theshit vulnerable to unsafe loading of user-owned Python rules when running as root.
MEDIUM (6.7)
theshit is a command-line utility that automatically detects and fixes common mistakes in shell commands. Prior to version 0.1.1, the application loads custom Python rules and configuration files from user-writable locations (e.g., `~/.config/theshit/`) without validating ownership or permissions when executed with elevated privileges. If the tool is invoked with `sudo` or otherwise runs with an effective UID of root, it continues to trust configuration files originating from the unprivileged user's environment. This allows a local attacker to inject arbitrary Python code via a malicious rule or configuration file, which is then executed with root privileges. Any system where this tool is executed with elevated privileges is affected. In environments where the tool is permitted to run via `sudo` without a password (`NOPASSWD`), a local unprivileged user can escalate privileges to root without additional interaction. The issue has been fixed in version 0.1.1. The patch introduces strict ownership and permission checks for all configuration files and custom rules. The application now enforces that rules are only loaded if they are owned by the effective user executing the tool. When executed with elevated privileges (`EUID=0`), the application refuses to load any files that are not owned by root or that are writable by non-root users. When executed as a non-root user, it similarly refuses to load rules owned by other users. This prevents both vertical and horizontal privilege escalation via execution of untrusted code. If upgrading is not possible, users should avoid executing the application with `sudo` or as the root user. As a temporary mitigation, ensure that directories containing custom rules and configuration files are owned by root and are not writable by non-root users. Administrators may also audit existing custom rules before running the tool with elevated privileges.
Published: 2025-12-30T19:15:17.267Z
Updated: 2025-12-30T19:28:19.205Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.