Approved changes feed: RSS · Atom

cpe:2.3:a:wp_cloud_plugins/_deleeuw_:use-your-drive_|_google_drive_plugin_for_wordpress:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorWp Cloud Plugins/ Deleeuw (cf6427a2-99bb-5e44-a0df-ebc171c28b1d)
ProductUse Your Drive | Google Drive Plugin For Wordpress (33ff84ff-eafd-5545-8fbf-962c683972db)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-93031 vulnerable 2026-10-13 12:28:56.236476 WP Cloud Plugins Use-your-Drive, Out-of-the-Box, Share-one-Drive, and Lets-Box <= 3.8.3 - Authenticated (Subscriber+) Arbitrary File Upload via Media Import
HIGH (8.8)
The WP Cloud Plugins Use-your-Drive, Out-of-the-Box, Share-one-Drive, and Lets-Box plugins for WordPress are vulnerable to Arbitrary File Upload in all versions from 2.0 up to, and including, 3.8.3 via the download_file_to_uploads function. This is due to the import action being registered for unauthenticated users via wp_ajax_nopriv_, a missing capability check in can_import(), and the imported file's extension and contents not being validated against get_allowed_mime_types() before it is written to the uploads directory. This makes it possible for authenticated attackers, with subscriber-level access and above, to upload files that may be executable, which makes remote code execution possible.
Published: 2026-09-18T19:36:29.297Z
Updated: 2026-09-19T14:11:38.229Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-7050 vulnerable 2026-06-08 07:43:17.932741 Use-your-Drive | Google Drive plugin for WordPress <= 3.3.1- Unauthenticated Stored Cross-Site Scripting via File Metadata
HIGH (7.2)
The Use-your-Drive | Google Drive plugin for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'title' parameter in file metadata in all versions up to, and including, 3.3.1 due to insufficient input sanitization and output escaping. This makes it possible for attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability can be exploited by the lowest authentication level permitted to upload files, including unauthenticated users, once a file upload shortcode is published on a publicly accessible post.
Published: 2025-08-05T06:39:48.769Z
Updated: 2026-04-08T17:28:13.487Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.