Approved changes feed: RSS · Atom

cpe:2.3:a:avishika:avishi_wp_paypal_payment_button:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorAvishika (89f0e688-0604-559b-b55a-00dda4f8460e)
ProductAvishi Wp Paypal Payment Button (2d04d263-c1f7-5ba9-9707-0112b75e181e)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-7669 vulnerable 2026-06-08 07:45:17.891074 Avishi WP PayPal Payment Button <= 2.0 - Cross-Site Request Forgery to Stored Cross-Site Scripting
MEDIUM (6.1)
The Avishi WP PayPal Payment Button plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.0. This is due to missing or incorrect nonce validation on the 'avishi-wp-paypal-payment-button/index.php' page. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2025-07-19T02:22:58.889Z
Updated: 2026-04-08T17:04:18.978Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.