Approved changes feed: RSS · Atom

cpe:2.3:a:beyondcart:beyondcart_connector:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorBeyondcart (23d0cf17-eec3-5b4b-a3b3-554353ce42ee)
ProductBeyondcart Connector (b554c433-4ef4-5e69-b785-934ab388349d)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-8570 vulnerable 2026-06-08 07:45:20.754368 BeyondCart Connector <= 3.0.1 - Missing Configuration of JWT Secret to Unauthenticated Privilege Escalation via determine_current_user Filter
CRITICAL (9.8)
The BeyondCart Connector plugin for WordPress is vulnerable to Privilege Escalation due to improper JWT secret management and authorization within the determine_current_user filter in versions 1.4.2 through 3.0.1. This makes it possible for unauthenticated attackers to craft valid tokens and assume any user’s identity.
Published: 2025-09-11T07:24:59.419Z
Updated: 2026-04-08T17:24:57.326Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.