Approved changes feed: RSS · Atom
cpe:2.3:a:packistryphp:packistry:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Packistryphp (63137b60-c737-56e8-8fe2-6774c85d1b00) |
|---|---|
| Product | Packistry (e0f90fea-08ee-5ed3-a068-c9b44e421cb3) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/packistry/packistry |
purl2cpe | 2026-07-28 16:40:52.319605 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-27968 |
vulnerable | 2026-06-08 07:55:14.739084 |
Packistry accepts expired access tokens
MEDIUM (4.3)
Packistry is a self-hosted Composer repository designed to handle PHP package distribution. Prior to version 0.13.0, RepositoryAwareController::authorize() verified token presence and ability, but did not enforce token expiration. As a result, an expired deploy token with the correct ability could still access repository endpoints (e.g., Composer metadata/download APIs). The fix in version 0.13.0 adds an explicit expiration check, and tests now test expired deploy tokens to ensure they are rejected.
Published: 2026-02-26T01:57:12.752Z
Updated: 2026-02-26T14:53:10.334Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.