Approved changes feed: RSS · Atom

cpe:2.3:a:twentig:twentig_supercharged_block_editor_–_blocks,_patterns,_starter_sites,_portfolio:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorTwentig (6bea08ca-663e-54c4-9156-a955ddc1be9c)
ProductTwentig Supercharged Block Editor – Blocks, Patterns, Starter Sites, Portfolio (88d0f5e0-ef95-5001-a375-e1bac906348b)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-2602 vulnerable 2026-06-08 07:55:17.273081 Twentig <= 1.9.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'featuredImageSizeWidth'
MEDIUM (6.4)
The Twentig plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'featuredImageSizeWidth' parameter in versions up to, and including, 1.9.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-03-29T01:24:46.055Z
Updated: 2026-04-08T17:32:14.691Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.