Approved changes feed: RSS · Atom
cpe:2.3:a:vanna-ai:vanna:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Vanna Ai (0da1831f-5be4-5a92-80be-0f2b1ea93d9c) |
|---|---|
| Product | Vanna (3d7c4586-0626-51f4-a04a-e35dab6107cc) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from gcve-enriched-dumps CVE data
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
| No PURL mappings for this CPE yet. | ||
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-65702 |
vulnerable | 2026-07-29 01:06:20.229293 |
Vanna 2.0.2 Path Traversal via FileSystemConversationStore
HIGH (8.6)
Vanna through 2.0.2 contains a path traversal vulnerability in the FileSystemConversationStore persistence integration that allows unauthenticated remote attackers to write attacker-controlled JSON files to arbitrary filesystem locations and read conversation metadata from outside the intended store base directory. Attackers can supply path traversal sequences in the conversation_id parameter submitted to the unauthenticated chat API endpoints to escape the base directory during both write and read operations, enabling arbitrary file write with attacker-controlled content and unauthorized file read on the server filesystem.
Published: 2026-07-23T17:09:37.574Z
Updated: 2026-07-23T17:43:42.379Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-6977 |
vulnerable | 2026-06-08 08:07:05.219545 |
vanna-ai vanna Legacy Flask API improper authorization
HIGH (7.3)
A security vulnerability has been detected in vanna-ai vanna up to 2.0.2. The affected element is an unknown function of the component Legacy Flask API. The manipulation leads to improper authorization. It is possible to initiate the attack remotely. The exploit has been disclosed publicly and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
Published: 2026-04-25T10:15:14.127Z
Updated: 2026-04-27T13:34:28.591Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-5321 |
vulnerable | 2026-06-08 08:07:03.554070 |
vanna-ai vanna FastAPI/Flask Server cross-domain policy
MEDIUM (4.3)
A flaw has been found in vanna-ai vanna up to 2.0.2. Affected by this issue is some unknown functionality of the component FastAPI/Flask Server. Executing a manipulation can lead to permissive cross-domain policy with untrusted domains. The attack can be launched remotely. The exploit has been published and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
Published: 2026-04-02T04:45:11.472Z
Updated: 2026-04-02T18:30:05.222Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-5320 |
vulnerable | 2026-06-08 08:07:03.553599 |
vanna-ai vanna Chat API Endpoint v2 missing authentication
HIGH (7.3)
A vulnerability was detected in vanna-ai vanna up to 2.0.2. Affected by this vulnerability is an unknown functionality of the file /api/vanna/v2/ of the component Chat API Endpoint. Performing a manipulation results in missing authentication. The attack can be initiated remotely. The exploit is now public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
Published: 2026-04-02T03:45:11.517Z
Updated: 2026-04-02T13:32:13.296Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-4513 |
vulnerable | 2026-06-08 08:05:13.464139 |
vanna-ai vanna base.py ask sql injection
MEDIUM (6.3)
A vulnerability was detected in vanna-ai vanna up to 2.0.2. Affected by this vulnerability is the function ask of the file vanna\legacy\base\base.py. Performing a manipulation results in sql injection. The attack is possible to be carried out remotely. The exploit is now public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
Published: 2026-03-21T10:02:11.763Z
Updated: 2026-03-23T16:30:05.313Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-4511 |
vulnerable | 2026-06-08 08:05:13.462122 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-4231 |
vulnerable | 2026-06-08 08:05:13.050805 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-4230 |
vulnerable | 2026-06-08 08:05:13.050353 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-4229 |
vulnerable | 2026-06-08 08:05:13.049932 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.