Approved changes feed: RSS · Atom

cpe:2.3:a:byybora:google_pagerank_display:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorByybora (e7a678c9-cb46-5851-a623-2b589258905e)
ProductGoogle Pagerank Display (c5b344a0-a7e0-5e6a-b404-7bdd07af60fe)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-6294 vulnerable 2026-06-08 08:07:04.641204 Google PageRank Display <= 1.4 - Cross-Site Request Forgery to Settings Update via Settings Page
MEDIUM (4.3)
The Google PageRank Display plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to and including 1.4. This is due to missing nonce validation in the gpdisplay_option() function, which handles the plugin settings page. The settings form does not include a wp_nonce_field(), and the form handler does not call check_admin_referer() or wp_verify_nonce() before processing the POST request. This makes it possible for unauthenticated attackers to trick a logged-in administrator into submitting a crafted request that changes the plugin's settings (stored via update_option()), such as the display style used to render the PageRank badge.
Published: 2026-04-22T07:45:42.426Z
Updated: 2026-04-22T12:07:22.564Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.