Approved changes feed: RSS · Atom

cpe:2.3:a:askywhale:games_catalog:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorAskywhale (bc3eb05d-2b7e-577a-8351-02499f5e4491)
ProductGames Catalog (5891465a-949c-5fde-ba5f-261b5bbde36f)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from gcve-enriched-dumps CVE data

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-8418 vulnerable 2026-06-08 08:08:58.356032 Games Catalog <= 1.2.0 - Cross-Site Request Forgery to Arbitrary Game/Post Deletion
MEDIUM (4.3)
The Games Catalog plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.2.0. This is due to missing or incorrect nonce validation on the gc_crud() function which handles the delete action (action=delete) via a GET request without any wp_verify_nonce() / check_admin_referer() call. This makes it possible for unauthenticated attackers to delete arbitrary game catalog entries (including the associated WordPress post created for the game) via a forged request, granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2026-05-20T01:25:44.064Z
Updated: 2026-05-20T13:17:27.823Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.