Zenspider Ruby Parser-legacy 1.0.0 for Ruby
Approved changes feed: RSS · Atom
cpe:2.3:a:zenspider:ruby_parser-legacy:1.0.0:*:*:*:*:ruby:*:*part: a version: 1.0.0 update: *
| Vendor | Zenspider (5bca23c7-e822-5702-944e-097f7771169b) |
|---|---|
| Product | Ruby Parser Legacy (e7062c3e-20af-5b4d-bb09-9ae2e5240cc0) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | ruby |
| Target hardware | * |
| Other | * |
Notes
Imported from NVD CPE 2.0 feed
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:gem/ruby_parser-legacy |
purl2cpe | 2026-06-01 10:17:09.747941 |
pkg:github/zenspider/ruby_parser-legacy |
purl2cpe | 2026-06-01 10:17:09.747944 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2019-18409 |
vulnerable | 2026-06-08 05:13:11.496766 |
Details available
The ruby_parser-legacy (aka legacy) gem 1.0.0 for Ruby allows local privilege escalation because of world-writable files. For example, if the brakeman gem (which has a legacy dependency) 4.5.0 through 4.7.0 is used, a local user can insert malicious code into the ruby_parser-legacy-1.0.0/lib/ruby_parser/legacy/ruby_parser.rb file.
Published: 2019-10-24T13:59:19.000Z
Updated: 2024-08-05T01:54:14.406Z Reference links |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.