PuTTY 0.53
Approved changes feed: RSS · Atom
cpe:2.3:a:simon_tatham:putty:0.53:*:*:*:*:*:*:*
part: a version: 0.53 update: *
| Vendor | Simon Tatham (028e5a99-0a12-552a-a31f-7f988487cba5) |
|---|---|
| Product | Putty (e4cd4493-2350-547b-b7f4-d0f6efa8cabb) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
| Notes | Imported from NVD CPE 2.0 feed |
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:deb/debian/putty |
purl2cpe | 2026-06-01 10:18:20.134418 |
pkg:deb/ubuntu/putty |
purl2cpe | 2026-06-01 10:18:20.134419 |
pkg:github/github/putty |
purl2cpe | 2026-06-01 10:18:20.134421 |
pkg:github/kasperdeng/putty |
purl2cpe | 2026-06-01 10:18:20.134422 |
pkg:github/larryli/putty |
purl2cpe | 2026-06-01 10:18:20.134423 |
pkg:rpm/fedora/putty |
purl2cpe | 2026-06-01 10:18:20.134425 |
pkg:rpm/opensuse/putty |
purl2cpe | 2026-06-01 10:18:20.134426 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2015-2157 |
vulnerable | 2026-06-08 05:06:27.628487 |
Details available
The (1) ssh2_load_userkey and (2) ssh2_save_userkey functions in PuTTY 0.51 through 0.63 do not properly wipe SSH-2 private keys from memory, which allows local users to obtain sensitive information by reading the memory.
Published: 2015-03-27T14:00:00.000Z
Updated: 2024-08-06T05:10:14.276Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2013-4852 |
vulnerable | 2026-06-08 05:04:49.965520 |
Details available
Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.
Published: 2013-08-19T23:00:00.000Z
Updated: 2024-08-06T16:59:40.996Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2013-4208 |
vulnerable | 2026-06-08 05:04:34.616962 |
Details available
The rsa_verify function in PuTTY before 0.63 (1) does not clear sensitive process memory after use and (2) does not free certain structures containing sensitive process memory, which might allow local users to discover private RSA and DSA keys.
Published: 2013-08-19T23:00:00.000Z
Updated: 2024-08-06T16:38:01.962Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2013-4207 |
vulnerable | 2026-06-08 05:04:34.616210 |
Details available
Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) via an invalid DSA signature that is not properly handled during computation of a modular inverse and triggers the overflow during a division by zero by the bignum functionality, a different vulnerability than CVE-2013-4206.
Published: 2013-08-19T23:00:00.000Z
Updated: 2024-08-06T16:38:01.696Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2013-4206 |
vulnerable | 2026-06-08 05:04:34.615325 |
Details available
Heap-based buffer underflow in the modmul function in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) and possibly trigger memory corruption or code execution via a crafted DSA signature, which is not properly handled when performing certain bit-shifting operations during modular multiplication.
Published: 2013-08-19T23:00:00.000Z
Updated: 2024-08-06T16:38:01.677Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.