Approved changes feed: RSS · Atom

cpe:2.3:a:smartsoft:button_widget_smartsoft:1.0.1:*:*:*:*:wordpress:*:*

part: a version: 1.0.1 update: *

VendorSmartsoft (15fb3cbd-24f3-5a03-a31b-0354fa1c480a)
ProductButton Widget Smartsoft (288f3771-a031-558d-99e1-37fe8fb7c5a6)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*
NotesImported from NVD CPE 2.0 feed

PURL mappings

PURLSourceLast updated
No PURL mappings for this CPE yet.

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2022-1912 vulnerable 2026-06-08 05:39:14.215736 Button Widget Smartsoft <= 1.0.1 - Cross-Site Request Forgery to Cross-Site Scripting
HIGH (8.8)
The Button Widget Smartsoft plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.0.1. This is due to missing nonce validation on the smartsoftbutton_settings page. This makes it possible for unauthenticated attackers to update the plugins settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2022-07-18T16:16:27.000Z
Updated: 2026-04-08T16:53:04.877Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.