Approved changes feed: RSS · Atom

cpe:2.3:a:weave.works:gitops:0.9.0:rc3:*:*:enterprise:*:*:*

part: a version: 0.9.0 update: rc3

VendorWeave.Works (edb14047-8327-545e-abd5-22f255096efc)
ProductGitops (b06c462e-68fa-528a-b71c-659086341175)
Edition*
Language*
Software editionenterprise
Target software*
Target hardware*
Other*

Notes

Imported from NVD CPE 2.0 feed

PURL mappings

PURLSourceLast updated
pkg:github/weaveworks/weave-gitops purl2cpe 2026-06-01 10:11:45.186088

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2022-38790 vulnerable 2026-06-08 05:47:17.423144 Details available
Weave GitOps Enterprise before 0.9.0-rc.5 has a cross-site scripting (XSS) bug allowing a malicious user to inject a javascript: link in the UI. When clicked by a victim user, the script will execute with the victim's permission. The exposure appears in Weave GitOps Enterprise UI via a GitopsCluster dashboard link. An annotation can be added to a GitopsCluster custom resource.
Published: 2022-09-01T12:55:42.000Z
Updated: 2024-08-03T11:02:14.604Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.